Transform this CurveUV by the given 2D affine transform if possible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public CurveUV Transform( Transform2D trfUV ) |
Visual Basic |
---|
Public Function Transform ( _ trfUV As Transform2D _ ) As CurveUV |
Visual C++ |
---|
public: CurveUV^ Transform( Transform2D^ trfUV ) |
Parameters
- trfUV
- Type: Autodesk.Revit.DB..::..Transform2D
The given 2D affine transform.
Return Value
If successful a transformed CurveUV, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |