An affine transform of 2D Euclidean space.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public class Transform2D : IDisposable |
Visual Basic |
---|
Public Class Transform2D _ Implements IDisposable |
Visual C++ |
---|
public ref class Transform2D : IDisposable |
Remarks
An affine transform is a linear transform plus a translation (which may be zero).
Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Transform2D
Autodesk.Revit.DB..::..Transform2D