Gets the components of roof slabs.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static RoofComponents GetRoofComponents( ExporterIFC exporterIFC, RoofBase roof ) |
Visual Basic |
---|
Public Shared Function GetRoofComponents ( _ exporterIFC As ExporterIFC, _ roof As RoofBase _ ) As RoofComponents |
Visual C++ |
---|
public: static RoofComponents^ GetRoofComponents( ExporterIFC^ exporterIFC, RoofBase^ roof ) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- roof
- Type: Autodesk.Revit.DB..::..RoofBase
The roof element.
Return Value
The roof components.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |