ExporterIFCUtilsGetRoofComponents Method |
Gets the components of roof slabs.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RoofComponents GetRoofComponents(
ExporterIFC exporterIFC,
RoofBase roof
)
Public Shared Function GetRoofComponents (
exporterIFC As ExporterIFC,
roof As RoofBase
) As RoofComponents
public:
static RoofComponents^ GetRoofComponents(
ExporterIFC^ exporterIFC,
RoofBase^ roof
)
static member GetRoofComponents :
exporterIFC : ExporterIFC *
roof : RoofBase -> RoofComponents
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- roof RoofBase
-
The roof element.
Return Value
RoofComponents
The roof components.
Exceptions
See Also