TransferringProjectStandardsEventArgs Class

The event arguments used by the TransferringProjectStandards event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPreDocEventArgs
          Autodesk.Revit.UI.EventsTransferringProjectStandardsEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TransferringProjectStandardsEventArgs : RevitAPIPreDocEventArgs

The TransferringProjectStandardsEventArgs type exposes the following members.

Properties
 NameDescription
Public propertySourceDocument Source document.
Public propertyTargetDocument Target document.
Top
Methods
 NameDescription
Public methodGetExternalItems Gets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.
Public methodSetExternalItems Sets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.
Top
See Also