ParameterMap Class

A map that can contain a mapping of a parameter name (a String) to a parameter.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBParameterMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterMap : APIObject, 
	IEnumerable

The ParameterMap type exposes the following members.

Constructors
 NameDescription
Public methodParameterMapInitializes a new instance of the ParameterMap class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the map is empty.
Public propertyItemGets or sets an item at a specified key within the map.
Public propertySizeReturns the number of objects that are in the map.
Top
Methods
 NameDescription
Public methodClearRemoves every item from the map, rendering it empty.
Public methodContainsTests for the existence of a key within the map.
Public methodEraseRemoves a object with the specified key from the map.
Public methodForwardIteratorRetrieve a forward moving iterator to the map.
Public methodGetEnumeratorRetrieve a forward moving iterator to the map.
Public methodInsertInsert the specified item with the specified key into the map.
Public methodReverseIteratorRetrieve a backward moving iterator to the map.
Top
See Also