ParameterDownloadOptions(ISetElementId, Boolean, Boolean, ForgeTypeId) Constructor |
Creates a new ParameterDownloadOptions instance.
Category bindings are represented by an ElementIdSet populated with category identifiers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ParameterDownloadOptions(
ISet<ElementId> categories,
bool isInstance,
bool visible,
ForgeTypeId groupTypeId
)
Public Sub New (
categories As ISet(Of ElementId),
isInstance As Boolean,
visible As Boolean,
groupTypeId As ForgeTypeId
)
public:
ParameterDownloadOptions(
ISet<ElementId^>^ categories,
bool isInstance,
bool visible,
ForgeTypeId^ groupTypeId
)
new :
categories : ISet<ElementId> *
isInstance : bool *
visible : bool *
groupTypeId : ForgeTypeId -> ParameterDownloadOptions
Parameters
- categories ISetElementId
-
The category identifiers.
- isInstance Boolean
-
True if binding to Element instances, false if binding to Element types.
- visible Boolean
-
True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
- groupTypeId ForgeTypeId
-
Properties palette group identifier.
Exceptions
See Also