ParameterDownloadOptions Class

An option class used for downloading parameters from the Parameters Service.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBParameterDownloadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterDownloadOptions : IDisposable

The ParameterDownloadOptions type exposes the following members.

Constructors
 NameDescription
Public methodParameterDownloadOptions Default constructor.
Public methodParameterDownloadOptions(ISetElementId, Boolean, Boolean, ForgeTypeId) Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.
Top
Properties
 NameDescription
Public propertyIsInstance True if binding to Element instances, false if binding to Element types.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyVisible True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ParameterDownloadOptions
Public methodGetCategories Get categories for binding.
Public methodGetGroupTypeId Get properties palette group identifier.
Public methodSetCategories Set categories for binding.
Public methodSetGroupTypeId Set properties palette group identifier.
Top
See Also