ExternallyTaggedGeometryObject Class

Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternallyTaggedGeometryObject
    Autodesk.Revit.DBExternallyTaggedBRep
    Autodesk.Revit.DBExternallyTaggedNonBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedGeometryObject : IDisposable

The ExternallyTaggedGeometryObject type exposes the following members.

Properties
 NameDescription
Public propertyExternalId The external Id of the geometry object.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternallyTaggedGeometryObject
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also