ExternallyTaggedNonBRep Class

This class is used to create an externally tagged geometry object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternallyTaggedGeometryObject
    Autodesk.Revit.DBExternallyTaggedNonBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedNonBRep : ExternallyTaggedGeometryObject

The ExternallyTaggedNonBRep type exposes the following members.

Constructors
 NameDescription
Public methodExternallyTaggedNonBRep Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.
Top
Properties
 NameDescription
Public propertyExternalId The external Id of the geometry object.
(Inherited from ExternallyTaggedGeometryObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternallyTaggedGeometryObject)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ExternallyTaggedGeometryObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetUsage Controls the usage of this ExternallyTaggedNonBRep.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also