ExternallyTaggedBRep Class

An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternallyTaggedGeometryObject
    Autodesk.Revit.DBExternallyTaggedBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternallyTaggedBRep : ExternallyTaggedGeometryObject

The ExternallyTaggedBRep type exposes the following members.

Properties
 NameDescription
Public propertyExternalId The external Id of the geometry object.
(Inherited from ExternallyTaggedGeometryObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternallyTaggedGeometryObject)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ExternallyTaggedGeometryObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTaggedGeometry Returns the externally tagged geometry object.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also