ImporterIFCUtilsUpdateDirectShapeCategory Method |
Updates the category of a DirectShape.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void UpdateDirectShapeCategory(
DirectShape directShape,
ElementId newCategoryId
)
Public Shared Sub UpdateDirectShapeCategory (
directShape As DirectShape,
newCategoryId As ElementId
)
public:
static void UpdateDirectShapeCategory(
DirectShape^ directShape,
ElementId^ newCategoryId
)
static member UpdateDirectShapeCategory :
directShape : DirectShape *
newCategoryId : ElementId -> unit
Parameters
- directShape DirectShape
-
The DirectShape.
- newCategoryId ElementId
-
The new category id.
Exceptions
Remarks
Use this function carefully, as it could result in a mismatch between DirectShape
and DirectShapeType categories.
See Also