ElementIsCurveDrivenFilter Class

A filter used to match elements which are curve driven.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementIsCurveDrivenFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementIsCurveDrivenFilter : ElementQuickFilter

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementIsCurveDrivenFilter Constructs a new instance of a filter to match only curve driven elements.
Public methodElementIsCurveDrivenFilter(Boolean) Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
// Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
// The term "curve driven" indicates that the element's Location property is a LocationCurve
ElementIsCurveDrivenFilter filter = new ElementIsCurveDrivenFilter();

// Apply the filter to the elements in the active document,
// Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns 
// are placed at a single point).
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> slantColumns = collector
    .WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements();

// Find elements of not curve driven: use inverted filter to match elements
ElementIsCurveDrivenFilter notCurveDrivenFilter = new ElementIsCurveDrivenFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveDrivenFounds = collector.WherePasses(notCurveDrivenFilter).ToElements();
See Also