ElementIsCurveDrivenFilter(Boolean) Constructor |
Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementIsCurveDrivenFilter(
bool inverted
)
Public Sub New (
inverted As Boolean
)
public:
ElementIsCurveDrivenFilter(
bool inverted
)
new :
inverted : bool -> ElementIsCurveDrivenFilter
Parameters
- inverted Boolean
-
True if the filter should match all elements which are not curve driven elements.
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve.
Example elements found by this filter include walls, beams, and curve elements.
See Also