DefinitionGroup Class

The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DefinitionGroup : APIObject

The DefinitionGroup type exposes the following members.

Properties
 NameDescription
Public propertyDefinitionsThe Definitions property returns an object that contains all the shared parameter definitions within the group.
Public propertyNameReturns the name of the parameter group.
Top
Methods
 NameDescription
Top
Remarks
Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.
See Also