DimensionSegmentArray Class

An array that can contain any number of DimensionSegment objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDimensionSegmentArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DimensionSegmentArray : APIObject, 
	IEnumerable

The DimensionSegmentArray type exposes the following members.

Constructors
 NameDescription
Public methodDimensionSegmentArrayInitializes a new instance of the DimensionSegmentArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets an item at a specified index within the array.
Public propertySizeReturns the number of objects that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the item to the end of the array.
Public methodClearRemoves every item from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsertInsert the specified item into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also