ExternalCommandData Class

A class contains reference to Application and View which are needed by external command.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.UIExternalCommandData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalCommandData : APIObject

The ExternalCommandData type exposes the following members.

Properties
 NameDescription
Public propertyApplication Retrieves an object that represents the current Application for external command.
Public propertyCode exampleJournalDataA data map that can be used to read and write data to the Autodesk Revit journal file.
Public propertyView Retrieves an object that represents the View external command work on.
Top
Methods
 NameDescription
Top
See Also