DocumentPreviewSettings Class

Contains the settings related to the saving of preview images for a given document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentPreviewSettings : IDisposable

The DocumentPreviewSettings type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyIsViewUpdateForced Identifies if Revit will update the preview view if necessary.
Public propertyPreviewViewId The view id that will be used to generate the preview.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DocumentPreviewSettings
Public methodForceViewUpdate Sets Revit to update the preview view if necessary.
Public methodIsViewIdValidForPreview Identifies if the view id is valid as a preview view id.
Top
Example
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));

Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);

// Set the preview settings
using (Transaction setTransaction = new Transaction(document, "Set preview view id"))
{
   setTransaction.Start();
   settings.PreviewViewId = viewForPreview.Id;
   setTransaction.Commit();
}

// Save the document
document.Save();
See Also