DocumentPreviewSettingsForceViewUpdate Method |
Sets Revit to update the preview view if necessary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ForceViewUpdate(
bool forceViewUpdate
)
Public Sub ForceViewUpdate (
forceViewUpdate As Boolean
)
public:
void ForceViewUpdate(
bool forceViewUpdate
)
member ForceViewUpdate :
forceViewUpdate : bool -> unit
Parameters
- forceViewUpdate Boolean
-
True to force update of the preview view. False to skip update if necessary (the default).
RemarksAn update is necessary if the view has never been displayed, or if
the model has been changed and the view has not been updated or accessed.
If the preview view has not been updated, the preview may not be properly
saved.
This setting applies only to a single Save operation and is reset to
false after it is accessed.
See Also