DocumentPreviewSettingsPreviewViewId Property |
The view id that will be used to generate the preview.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId PreviewViewId { get; set; }
Public Property PreviewViewId As ElementId
Get
Set
public:
property ElementId^ PreviewViewId {
ElementId^ get ();
void set (ElementId^ value);
}
member PreviewViewId : ElementId with get, set
Property Value
ElementId
InvalidElementId signals that there is no permanent preview view for the document.
Where possible the document's active view will be used to generate the preview upon save;
where there is no active view the document will not include a preview.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The view id is not valid to use as a preview view.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
This view will always be saved as the preview view for the document unless it is overridden
by the value used in SaveOptions or SaveAsOptions.
See Also