DrawContextFlushBuffer Method |
Submits geometry for rendering.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void FlushBuffer(
VertexBuffer vertexBuffer,
int vertexCount,
IndexBuffer indexBuffer,
int indexCount,
VertexFormat vertexFormat,
EffectInstance effectInstance,
PrimitiveType primitiveType,
int start,
int primitiveCount
)
Public Shared Sub FlushBuffer (
vertexBuffer As VertexBuffer,
vertexCount As Integer,
indexBuffer As IndexBuffer,
indexCount As Integer,
vertexFormat As VertexFormat,
effectInstance As EffectInstance,
primitiveType As PrimitiveType,
start As Integer,
primitiveCount As Integer
)
public:
static void FlushBuffer(
VertexBuffer^ vertexBuffer,
int vertexCount,
IndexBuffer^ indexBuffer,
int indexCount,
VertexFormat^ vertexFormat,
EffectInstance^ effectInstance,
PrimitiveType primitiveType,
int start,
int primitiveCount
)
static member FlushBuffer :
vertexBuffer : VertexBuffer *
vertexCount : int *
indexBuffer : IndexBuffer *
indexCount : int *
vertexFormat : VertexFormat *
effectInstance : EffectInstance *
primitiveType : PrimitiveType *
start : int *
primitiveCount : int -> unit
Parameters
- vertexBuffer VertexBuffer
-
The vertex buffer that contains vertex data.
- vertexCount Int32
-
The number of vertices in the vertex buffer.
- indexBuffer IndexBuffer
-
The index buffer that contains indices into the vertex buffer.
- indexCount Int32
-
The number of indices in the index buffer.
- vertexFormat VertexFormat
-
The format of the vertices in the vertex buffer.
- effectInstance EffectInstance
-
The effect instance to be used for drawing this piece of geometry.
- primitiveType PrimitiveType
-
The type of geometry primitive used in the index buffer.
- start Int32
-
The first index to use for drawing.
- primitiveCount Int32
-
The number of primitives to draw.
ExceptionsException | Condition |
---|
ArgumentException |
A change in the graphics state has made the vertex buffer vertexBuffer invalid for rendering.
-or-
A change in the graphics state has made the index buffer indexBuffer invalid for rendering.
-or-
A change in the graphics state has made the vertex format vertexFormat invalid for rendering.
-or-
A change in the graphics state has made the effect instance effectInstance invalid for rendering.
-or-
The vertex format vertexFormat and the effect instance effectInstance do not match.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
See Also