PrimitiveType Enumeration |
Type of geometry primitive represented as a number.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum PrimitiveType
Public Enumeration PrimitiveType
public enum class PrimitiveType
MembersMember name | Value | Description |
---|
TriangleList | 0 |
Geometry consisting of a list of triangles.
|
LineList | 1 |
Geometry consisting of a list of line segments.
|
PointList | 2 |
Geometry consisting of a list of points.
|
See Also