FilteredElementIdIterator Class

An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilteredElementIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilteredElementIdIterator : IEnumerator<ElementId>

The FilteredElementIdIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FilteredElementIdIterator
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCurrent The current element id found by the iterator.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsDone Identifies if the iteration has completed.
Public methodMoveNext Increments the iterator to the next element id passing the filter.
Public methodReset Resets the iterator to the beginning.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also