FilteredElementIdIteratorIsDone Method |
Identifies if the iteration has completed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool
Return Value
Boolean
True if the iteration has no more matching elements. False if there are more element ids to be iterated.
ExceptionsException | Condition |
---|
InvalidOperationException |
The FilteredElementCollector that yielded this iterator has been reset by another operation.
No further iteration is permitted with this iterator.
|
See Also