FilteredElementIdIteratorMoveNext Method |
Increments the iterator to the next element id passing the filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool
Return Value
Boolean
True if there is another available element id passing the filter in this iterator.
False if the iterator has completed all available element ids.
ExceptionsException | Condition |
---|
InvalidOperationException |
The FilteredElementCollector that yielded this iterator has been reset by another operation.
No further iteration is permitted with this iterator.
-or-
The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion).
|
See Also