MathComparisonUtils Class

This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBMathComparisonUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MathComparisonUtils

The MathComparisonUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberIsAlmostEqual Checks if two doubles are almost equal, using the internal tolerance.
Public methodStatic memberIsAlmostZero Checks if value is almost zero, using the internal tolerance.
Public methodStatic memberIsGreaterThan Checks if value1 is strictly greater than value2, using the internal tolerance.
Public methodStatic memberIsGreaterThanOrAlmostEqual Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
Public methodStatic memberIsLessThan Checks if value1 is strictly less than value2, using the internal tolerance.
Public methodStatic memberIsLessThanOrAlmostEqual Checks if value1 is less than or almost equal to value2, using the internal tolerance.
Top
See Also