MathComparisonUtilsIsAlmostEqual Method

Checks if two doubles are almost equal, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsAlmostEqual(
	double value1,
	double value2
)

Parameters

value1  Double
The first value.
value2  Double
The second value.

Return Value

Boolean
True if two doubles are almost equal, false otherwise.
Exceptions
ExceptionCondition
ArgumentException The given value for value1 is not finite -or- The given value for value2 is not finite
See Also