ApplicationNewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Method |
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData NewFamilyInstanceCreationData(
Face face,
XYZ location,
XYZ referenceDirection,
FamilySymbol symbol
)
Public Function NewFamilyInstanceCreationData (
face As Face,
location As XYZ,
referenceDirection As XYZ,
symbol As FamilySymbol
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
Face^ face,
XYZ^ location,
XYZ^ referenceDirection,
FamilySymbol^ symbol
)
member NewFamilyInstanceCreationData :
face : Face *
location : XYZ *
referenceDirection : XYZ *
symbol : FamilySymbol -> FamilyInstanceCreationData
Parameters
- face Face
- A face of a geometry object.
- location XYZ
- Point on the face where the instance is to be placed.
- referenceDirection XYZ
- A vector that defines the direction of the family instance.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
Return Value
FamilyInstanceCreationData
See Also