StructuralSectionRound Class

Defines common set of parameters for structural section round contour.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionRound : StructuralSection

The StructuralSectionRound type exposes the following members.

Properties
 NameDescription
Public propertyCentroidHorizontal Distance from centroid to the left extremites along horizontal axis.
Public propertyCentroidVertical Distance from centroid to the upper extremites along vertical axis.
Public propertyDiameter Pipe Diameter.
Public propertyNameKey Name Key
Top
Methods
 NameDescription
Top
See Also