StructuralSection Class

The base class for StructuralSection specific classes, designed to provide common parameters and ability to differentiate between different structural section shapes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSection : IEnumerable, 
	IDisposable

The StructuralSection type exposes the following members.

Properties
 NameDescription
Public propertyAnalysisParams Common set of parameters for structural analysis.
Public propertyElasticModulusStrongAxis Elastic section modulus about main strong axis for calculation of bending stresses.
Public propertyElasticModulusWeakAxis Elastic section modulus about main weak axis for calculation of bending stresses.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMomentOfInertiaStrongAxis Moment of Inertia about main strong axis (I).
Public propertyMomentOfInertiaWeakAxis Moment of Inertia about main weak axis (I).
Public propertyNominalWeight Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
Public propertyPerimeter Painting surface of the unit length.
Public propertyPlasticModulusStrongAxis Plastic section modulus in bending about main strong axis (Z, Wpl).
Public propertyPlasticModulusWeakAxis Plastic section modulus in bending about main weak axis.
Public propertyPrincipalAxesAngle Rotation angle between the principal axes and cross section reference planes.
Public propertySectionArea Cross section area.
Public propertySectionNameKey A parameter in structural families which allows for family type identification. This will be used for data mapping during model exchange with another program, namely Advance Steel.
Public propertyShearAreaStrongAxis Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
Public propertyShearAreaWeakAxis Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
Public propertyStructuralSectionGeneralShape The general type of structural section shape.
Public propertyStructuralSectionShape The type of structural section shape.
Public propertyStructuralSectionShapeName A human readable string representing the structural section shape.
Public propertyTorsionalModulus Section modulus for calculations of torsion stresses (Ct).
Public propertyTorsionalMomentOfInertia Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
Public propertyWarpingConstant Warping constant (Cw, Iomega, H).
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the StructuralSection
Public methodGetBoundarySize Returns size of the section boundary.
Public methodGetEnumerator 
Top
See Also