ExporterIFCUtilsGetConnectedWalls Method |
Obtains the IFC-specific information regarding the connections between this wall and other elements.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<IFCConnectedWallData> GetConnectedWalls(
Wall pWallElem,
IFCConnectedWallDataLocation locaction
)
Public Shared Function GetConnectedWalls (
pWallElem As Wall,
locaction As IFCConnectedWallDataLocation
) As IList(Of IFCConnectedWallData)
public:
static IList<IFCConnectedWallData^>^ GetConnectedWalls(
Wall^ pWallElem,
IFCConnectedWallDataLocation locaction
)
static member GetConnectedWalls :
pWallElem : Wall *
locaction : IFCConnectedWallDataLocation -> IList<IFCConnectedWallData>
Parameters
- pWallElem Wall
-
The wall.
- locaction IFCConnectedWallDataLocation
-
The location on the wall from where the connections should be obtained. This should be either
IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.
Return Value
IListIFCConnectedWallData
The connection information.
Exceptions
See Also