DirectContext3DHandleSettings Class

Overriding settings applied to DirectContext3DHandles through the Visibility dialog.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.DirectContext3DDirectContext3DHandleSettings

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectContext3DHandleSettings : IDisposable

The DirectContext3DHandleSettings type exposes the following members.

Constructors
 NameDescription
Public methodDirectContext3DHandleSettings Constructs an instance of settings with default values.
Public methodDirectContext3DHandleSettings(DirectContext3DHandleSettings) Constructs a copy of source object.
Public methodDirectContext3DHandleSettings(Boolean, Int32) Constructs an instance of settings with provided values.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyVisibility Visibility of the handle and the associated DirectContext3D graphics. A value of true means that the graphics are visible.
Top
Methods
 NameDescription
Public methodAssign Assigns values of the source settings to this object.
Public methodDisposeReleases all resources used by the DirectContext3DHandleSettings
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTransparency Gets the transparency value of the handle and the associated DirectContext3D graphics.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsEqual Check if the contents of two instances of settings are equal.
Public methodSetTransparency Sets the transparency value of the handle and the associated DirectContext3D graphics.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

DirectContext3D graphics can be displayed with or without an associated DirectContext3D handle element. For DirectContext3D graphics that utilize the handle element, the visibility and appearance of the graphics can be adjusted through the Visibility/Graphics dialog.

See Also