ExporterIFCGetLevelInfos Method |
Returns a collection containing the information about all levels in the document.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<ElementId, IFCLevelInfo> GetLevelInfos()
Public Function GetLevelInfos As IDictionary(Of ElementId, IFCLevelInfo)
public:
IDictionary<ElementId^, IFCLevelInfo^>^ GetLevelInfos()
member GetLevelInfos : unit -> IDictionary<ElementId, IFCLevelInfo>
Return Value
IDictionaryElementId,
IFCLevelInfo
The collection of level information.
Remarks
Level information is currently automatically collected and cached in the ExporterIFC
object. This method returns the cached information which is often needed during export
of particular building elements which reference levels, as well as to implement automatic
wall and column splitting.
See Also