CutFailureReason Enumeration |
The reason why a solid-solid cut cannot be created.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum CutFailureReason
Public Enumeration CutFailureReason
public enum class CutFailureReason
MembersMember name | Value | Description |
---|
CutAllowed | 0 |
Yes, the cutting element can add a cut to the target element.
|
CutAlreadyExists | 1 |
The cutting element has already cut the target element.
|
OppositeCutExists | 2 |
The target element has already cut the cutting element.
|
CutNotAppropriateForElements | 3 |
The cut is not appropriate for the two elements.
|
See Also