ConnectionValidationInfo Class

This object contains information about fabrication connection validations.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBConnectionValidationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConnectionValidationInfo : IDisposable

The ConnectionValidationInfo type exposes the following members.

Constructors
 NameDescription
Public methodConnectionValidationInfo Constructor.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConnectionValidationInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetWarning Access specific warning number of warnings generated by reload.
Public methodIsValidWarningIndex Validate warning index.
Public methodManyWarnings Returns number of warnings generated by reload.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also