FabricationConfigurationInfo Class

Represents an MEP object that holds the properties of an MEP fabrication configuration.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationConfigurationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationConfigurationInfo : IDisposable

The FabricationConfigurationInfo type exposes the following members.

Properties
 NameDescription
Public propertyCloudId The identifier of the cloud configuration.
Public propertyDescription The description of the fabrication configuration.
Public propertyGUID The unique identification of the fabrication configuration.
Public propertyIsCloudConfiguration Whether the cloud configuration is a remote cloud one.
Public propertyIsLocked Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the fabrication configuration.
Public propertyPath The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public propertyUnitSystem The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public propertyVersion The version of the fabrication configuration.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FabricationConfigurationInfo
Public methodStatic memberFindSourceFabricationConfiguration Finds the source fabrication configuration on disk which matches the input fabrication configuration.
Public methodStatic memberGetAllFabricationConfigurations Gets all added fabrication configurations.
Public methodGetProfiles Return the profiles in the fabrication configuration.
Public methodIsValid Checks if the fabrication configuration is valid.
Top
Remarks
To populate the Path property, you may need to call FindSourceFabricationConfiguration first.
See Also