FabricationConfigurationInfoFindSourceFabricationConfiguration Method

Finds the source fabrication configuration on disk which matches the input fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricationConfigurationInfo FindSourceFabricationConfiguration(
	FabricationConfigurationInfo fabricationConfiguration
)

Parameters

fabricationConfiguration  FabricationConfigurationInfo
The fabrication configuration to match.

Return Value

FabricationConfigurationInfo
The matching source fabrication configuration.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
Fabrication configuration is matched by configuration GUID and version. The GUIDs are required to be the same. For version, we first try to match the version exactly. If Revit cannot find an exact match, then it looks for the closest version later than the input configuration, then the closest earlier version.
See Also