ExporterIFCGetLevelInfo Method |
Returns an object representing the information about a level in the document.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCLevelInfo GetLevelInfo(
ElementId levelId
)
Public Function GetLevelInfo (
levelId As ElementId
) As IFCLevelInfo
public:
IFCLevelInfo^ GetLevelInfo(
ElementId^ levelId
)
member GetLevelInfo :
levelId : ElementId -> IFCLevelInfo
Parameters
- levelId ElementId
-
The level id.
Return Value
IFCLevelInfo
The level information.
Exceptions
Remarks
Level information is currently automatically collected and cached in the ExporterIFC
object. This method returns the cached information for a given level,
which is often needed during export of particular building elements which reference levels, as well
as to implement automatic wall and column splitting.
See Also