ThermalProperties Class

Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ThermalProperties : APIObject

The ThermalProperties type exposes the following members.

Properties
 NameDescription
Public propertyAbsorptance Value of absorptance.
Public propertyHeatTransferCoefficient The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyRoughness Value of roughness.
Public propertyThermalMass The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public propertyThermalResistance The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Top
Methods
 NameDescription
Top
See Also