ChangeType Class

A class representing a change that can be detected and tracked during Dynamic Update.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ChangeType : IDisposable

The ChangeType type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberConcatenateChangeTypes Creates a ChangeType that is a union of the two input ChangeTypes
Public methodContains Checks whether this ChangeType contains the input ChangeType
Public methodDisposeReleases all resources used by the ChangeType
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsIdentical Compares if two ChangeTypes are identical
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
ChangeTypes for specific changes can be obtained from the static methods available on Element.
See Also