ICodeCheckingParameterServer Interface

Interface for the code checking parameter server to implement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface ICodeCheckingParameterServer : IExternalServer

The ICodeCheckingParameterServer type exposes the following members.

Methods
 NameDescription
Public methodGetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer)
Public methodGetName Implement this method to return the name of the server.
(Inherited from IExternalServer)
Public methodGetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer)
Public methodGetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer)
Public methodGetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer)
Public methodPerformCodeChecking The server's method that will be called when Revit User clicks the Code Checking parameter's button from the properties palette.
Top
See Also