ICodeCheckingParameterServerPerformCodeChecking Method

The server's method that will be called when Revit User clicks the Code Checking parameter's button from the properties palette.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
bool PerformCodeChecking(
	CodeCheckingParameterServiceData data
)

Parameters

data  CodeCheckingParameterServiceData
The Code Checking data.

Return Value

Boolean
Indicates whether the code checking parameter server is executed successfully.
Remarks
The server provides UI way for Revit user to view and modify the detail data corresponding with the parameter value. The server may also modify the code checking parameter value itself during the execution. The method should always return 'true' if the server is successfully executed, no matter whether the server changes anything. Return 'false' or if the server throws, indicates a failed case, all changes made by the server will be discarded. A typical way to use the external server can be:
  • Implement a server class that derives from this interface
  • Create a new server object and register it with the service, see ExternalServiceRegistry.
  • Assign server to code checking instance.
See Also