LineProperties Class

A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLineProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineProperties : IDisposable

The LineProperties type exposes the following members.

Properties
 NameDescription
Public propertyColor The current color used when drawing lines/curves.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLineWidth The current width (thickness) of the pen stroke when drawing lines/curves.
Public propertyPatternId Id of the current Line pattern element used when drawing lines/curves.
Public propertyTransparency The current transparency level to be applied to the current color.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LineProperties
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
For more about using properties of this class refer to the interface IModelExportContext and its methods which handle geometric objects such as OnCurve(CurveNode), OnLineSegment(LineSegment), etc. LineProperties are available as a read-only property on the respective output nodes, i.e. CurveNode, LineSegment, etc.
See Also