IExportContextBaseOnLineSegment Method |
This method is called after unhandled curve was tessellated to line segments and sent to the output.
Note for 2D export: if the export is performed for the view in non-Wireframe display style, then
- this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
- this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxvoid OnLineSegment(
LineSegment segment
)
Sub OnLineSegment (
segment As LineSegment
)
void OnLineSegment(
LineSegment^ segment
)
abstract OnLineSegment :
segment : LineSegment -> unit
Parameters
- segment LineSegment
-
A structure describing the line segment.
See Also