LineSegment Class

An output node that represents a tessellated line segment.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLineSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LineSegment : IDisposable

The LineSegment type exposes the following members.

Properties
 NameDescription
Public propertyEndParameter Parameter associated with the end point.
Public propertyEndPoint End point of the line segment.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLineProperties Access to the line (pen) properties of the line
Public propertyStartParameter Parameter associated with the start point.
Public propertyStartPoint Start point of the line segment.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LineSegment
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See Also