IndexStreamPoint Class

A stream that can be used to write IndexPoint primitives into an IndexBuffer
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.DirectContext3DIndexStream
    Autodesk.Revit.DB.DirectContext3DIndexStreamPoint

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexStreamPoint : IndexStream

The IndexStreamPoint type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from IndexStream)
Top
Methods
 NameDescription
Public methodAddPoint Inserts a IndexPoint into the stream and associated buffer.
Public methodAddPoints Inserts multiple IndexPoint instances into the stream and associated buffer.
Public methodDispose
(Inherited from IndexStream)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also