IndexPoint Class

A point primitive consisting of one index.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.DirectContext3DIndexPrimitive
    Autodesk.Revit.DB.DirectContext3DIndexPoint

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexPoint : IndexPrimitive

The IndexPoint type exposes the following members.

Constructors
 NameDescription
Public methodIndexPoint Constructs the point primitive.
Top
Properties
 NameDescription
Public propertyIndex The index of the point's vertex.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from IndexPrimitive)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from IndexPrimitive)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodStatic memberGetSizeInShortInts Gets the amount of storage that the primitive takes up in a buffer, measured in short integers.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also