TextNoteOptions Class

Options to use when creating a new text note element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTextNoteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TextNoteOptions : IDisposable

The TextNoteOptions type exposes the following members.

Constructors
 NameDescription
Public methodTextNoteOptions Default constructor; populates the options with their respective default values.
Public methodTextNoteOptions(ElementId) Constructs text options to create text of the given type.
Top
Properties
 NameDescription
Public propertyHorizontalAlignment Horizontal alignment of the text.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyKeepRotatedTextReadable Flag controling whether a rotate text is to stay oriented to be always readable.
Public propertyRotation Base line angle of a text note, in radians.
Public propertyTypeId Id of a text type that defines the style of a text note.
Public propertyVerticalAlignment Vertical alignment of the text.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TextNoteOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Use an instance of this class as an argument in the TextNote.Create methods.
Example
#region Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)
#region Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
#endregion
#endregion
See Also