RoutingPreferenceManagerGetMEPPartId Method |
Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetMEPPartId(
RoutingPreferenceRuleGroupType groupType,
RoutingConditions conditions
)
Public Function GetMEPPartId (
groupType As RoutingPreferenceRuleGroupType,
conditions As RoutingConditions
) As ElementId
public:
ElementId^ GetMEPPartId(
RoutingPreferenceRuleGroupType groupType,
RoutingConditions^ conditions
)
member GetMEPPartId :
groupType : RoutingPreferenceRuleGroupType *
conditions : RoutingConditions -> ElementId
Parameters
- groupType RoutingPreferenceRuleGroupType
-
The routing preference group
- conditions RoutingConditions
-
A set of routing conditions
Return Value
ElementId
The Id of the fitting or segment that met the given routing conditions.
Exceptions
See Also