RoutingPreferenceRuleGroupType Enumeration

Add more rule group type here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RoutingPreferenceRuleGroupType
Members
Member nameValueDescription
Segments0 The segment types (e.g. pipe stocks)
Elbows1 The elbow types.
Junctions2 The junction types (e.g. takeoff, tee, wye, tap).
Crosses3 The cross types.
Transitions4 The transition types (Note that the multi-shape transitions may have their own groups).
Unions5 The union types that connect two segments together.
MechanicalJoints6 The mechanical joint types that connect fitting to fitting, segment to fitting, or segment to segment.
TransitionsRectangularToRound7 The multi-shape transition from the rectangular profile to the round profile.
TransitionsRectangularToOval8 The multi-shape transition from the rectangular profile to the oval profile.
TransitionsOvalToRound9 The multi-shape transition from the oval profile to the round profile.
Undefined-1 The undefined group type, the default initial value.
Caps10 The cap types
See Also